読者です 読者をやめる 読者になる 読者になる

scalaプラグインアップデート時のバグ?

scalaプラグインは最近頻繁にアップデートされているようだ。
そこで今日もアップデートしようとするとエラーが発生したので、現象と解決方法をメモ

環境

Eclipse3.4
Leopard10.5

エラー

scalaプラグインアップデートしようとしたら、以下エラーがでてUpdateに進ませてくれなかった。

Cannot complete the request.  See the details.
Format error in file: /tmp/p2Encoding51779.opb.

解決方法

そんな時は、Revert Configuration。何やら構成を元どおりに直してくれる処理をやってくれるらしい。
Help -> Software Updates -> Software Updates and Add-ons 画面が表示される
この後、画面右の[Revert Configuration]を押す
そしたらScala Eclipse Pluginを選択してFinish!!
Eclipseを再起動したら、アップデートされましたとさ。